Unverified Commit 72fccf10 authored by Raphaël Pinson's avatar Raphaël Pinson
Browse files

Remove tests for Puppet 2.7

parent 7f3c9993
......@@ -10,7 +10,6 @@ notifications:
env:
# base env
# Most tests with oldest supported ruby-augeas
- PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- PUPPET=3.0.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- PUPPET=3.2.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- PUPPET=3.4 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
......@@ -19,11 +18,8 @@ env:
# Use this build to publish on the forge
- PUPPET=3.4 RUBY_AUGEAS=0.5 FORGE_PUBLISH=true
# Test other versions of Augeas
- PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=0.10.0
- PUPPET=3.4 RUBY_AUGEAS=0.3.0 AUGEAS=0.10.0
- PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.0.0
- PUPPET=3.4 RUBY_AUGEAS=0.3.0 AUGEAS=1.0.0
- PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- PUPPET=3.4 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.2.0
- PUPPET=3.4 RUBY_AUGEAS=0.3.0 AUGEAS=1.2.0
......@@ -41,28 +37,18 @@ matrix:
exclude:
# base exclude
# No support for Ruby 2.0 before Puppet 3.2.0 and ruby-augeas 0.5
- rvm: 2.0.0
env: PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- rvm: 2.0.0
env: PUPPET=3.0.0 RUBY_AUGEAS=0.3.0
- rvm: 2.0.0
env: PUPPET=3.2.0 RUBY_AUGEAS=0.3.0
- rvm: 2.0.0
env: PUPPET=3.4 RUBY_AUGEAS=0.3.0
- rvm: 2.0.0
env: PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=0.10.0
- rvm: 2.0.0
env: PUPPET=3.4 RUBY_AUGEAS=0.3.0 AUGEAS=0.10.0
- rvm: 2.0.0
env: PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.0.0
- rvm: 2.0.0
env: PUPPET=3.4 RUBY_AUGEAS=0.3.0 AUGEAS=1.0.0
- rvm: 2.0.0
env: PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- rvm: 2.0.0
env: PUPPET=3.4 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- rvm: 2.0.0
env: PUPPET=2.7.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.2.0
- rvm: 2.0.0
env: PUPPET=3.0.0 RUBY_AUGEAS=0.3.0 AUGEAS=1.1.0
- rvm: 2.0.0
......
......@@ -25,7 +25,7 @@ group :development, :unit_tests do
gem 'json', '< 2.0', :require => false if RUBY_VERSION =~ /^1\.[89]/
gem 'json_pure', '< 2.0', :require => false if RUBY_VERSION =~ /^1\.[89]/
gem 'rspec-puppet', :require => false
gem 'puppetlabs_spec_helper', '< 1.2.0', :require => false
gem 'puppetlabs_spec_helper', :require => false
gem 'metadata-json-lint', :require => false
gem 'puppet-lint', :require => false
gem 'puppet-lint-unquoted_string-check', :require => false
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment