Commit ebcd1808 authored by mh's avatar mh
Browse files

refactor things for >2.7

parent e563b9aa
......@@ -5,8 +5,8 @@ class imapproxy::base {
}
file{'/etc/imapproxy.conf':
source => [ "puppet:///modules/site-imapproxy/${fqdn}/imapproxy.conf",
"puppet:///modules/site-imapproxy/imapproxy.conf",
source => [ "puppet:///modules/site_imapproxy/${::fqdn}/imapproxy.conf",
"puppet:///modules/site_imapproxy/imapproxy.conf",
"puppet:///modules/imapproxy/imapproxy.conf" ],
require => Package[up-imapproxy],
notify => Service[imapproxy],
......
class imapproxy::disable inherits imapproxy {
case $operatingsystem {
case $::operatingsystem {
default: { include imapproxy::disable::base }
}
}
......@@ -4,12 +4,12 @@
#
class imapproxy {
case $operatingsystem {
case $::operatingsystem {
gentoo: { include imapproxy::gentoo }
default: { include imapproxy::base }
}
if $use_shorewall {
if hiera('use_shorewall',false) {
include shorewall::rules::out::imap
}
}
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment