Commit 09fc1ea0 authored by Stefan Schulte's avatar Stefan Schulte
Browse files

Only run coverage on ruby >= 1.9

We also run our tests against ruby 1.8.7. Unfortunately SimpleCov does
not support ruby 1.8.7

Only run test coverage on recent ruby versions
parent faddabab
......@@ -6,4 +6,7 @@ facterversion = ENV.key?('FACTER_VERSION') ? ENV['FACTER_VERSION'] : ['>= 1.6']
gem 'puppet', puppetversion
gem 'puppetlabs_spec_helper', '>= 0.1.0'
gem 'facter', facterversion
gem 'coveralls', :require => false
unless RUBY_VERSION =~ /^1.8/
gem 'coveralls', :require => false
end
require 'rubygems'
require 'simplecov'
require 'coveralls'
unless RUBY_VERSION =~ /^1.8/
require 'simplecov'
require 'coveralls'
end
require 'puppetlabs_spec_helper/module_spec_helper'
SimpleCov.formatter = SimpleCov::Formatter::MultiFormatter[
unless RUBY_VERSION =~ /^1.8/
SimpleCov.formatter = SimpleCov::Formatter::MultiFormatter[
SimpleCov::Formatter::HTMLFormatter,
Coveralls::SimpleCov::Formatter
]
SimpleCov.start
SimpleCov.start do
]
SimpleCov.start
SimpleCov.start do
add_filter 'spec/'
end
end
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment