Commit 278c13cd authored by Stefan Schulte's avatar Stefan Schulte
Browse files

Update travis jobs

The environment variables inside Gemfile changed (adopted to puppet
module generate) so we also have to modify the travis file to set the
correct environment variables when testing against specific
puppet/facter versions
parent 8c31522e
......@@ -9,22 +9,19 @@ rvm:
- 1.8.7
- 1.9.3
- 2.0.0
- 2.1.5
env:
matrix:
- PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
- PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
- PUPPET_GEM_VERSION="~> 3.0"
- PUPPET_VERSION="~> 2.7.0" FACTER_VERSION="~> 1.6.0"
- PUPPET_VERSION="~> 2.7.0" FACTER_VERSION="~> 1.7.0"
- PUPPET_VERSION="~> 3.0"
matrix:
exclude:
- rvm: 1.9.3
env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
- rvm: 1.9.3
env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
- rvm: 2.0.0
env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.6.0"
env: PUPPET_VERSION="~> 2.7.0"
- rvm: 2.0.0
env: PUPPET_GEM_VERSION="~> 2.7.0" FACTER_GEM_VERSION="~> 1.7.0"
- rvm: 1.8.7
env: PUPPET_GEM_VERSION="~> 3.2.0"
env: PUPPET_VERSION="~> 2.7.0"
- rvm: 2.1.5
env: PUPPET_VERSION="~> 2.7.0"
notifications:
email: false
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment