Commit b81bd88e authored by Stefan Schulte's avatar Stefan Schulte
Browse files

Exclude unsupported ruby/puppet versions in tests

ruby 1.9 and above was not really supported before puppet 3.x [1] so don't
test any of these combinations. These combinations actually were
excluded before, but the matrix got messed up in the previous
commit.

[1] https://docs.puppetlabs.com/guides/platforms.html#ruby-versions
parent 278c13cd
......@@ -18,10 +18,16 @@ env:
matrix:
exclude:
- rvm: 1.9.3
env: PUPPET_VERSION="~> 2.7.0"
env: PUPPET_VERSION="~> 2.7.0" FACTER_VERSION="~> 1.6.0"
- rvm: 1.9.3
env: PUPPET_VERSION="~> 2.7.0" FACTER_VERSION="~> 1.7.0"
- rvm: 2.0.0
env: PUPPET_VERSION="~> 2.7.0" FACTER_VERSION="~> 1.6.0"
- rvm: 2.0.0
env: PUPPET_VERSION="~> 2.7.0"
env: PUPPET_VERSION="~> 2.7.0" FACTER_VERSION="~> 1.7.0"
- rvm: 2.1.5
env: PUPPET_VERSION="~> 2.7.0" FACTER_VERSION="~> 1.6.0"
- rvm: 2.1.5
env: PUPPET_VERSION="~> 2.7.0"
env: PUPPET_VERSION="~> 2.7.0" FACTER_VERSION="~> 1.7.0"
notifications:
email: false
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment