Commit faddabab authored by Stefan Schulte's avatar Stefan Schulte
Browse files

Integrate coveralls

parent dcfcf234
.*.sw[op]
.bundle/
pkg/
coverage/
Gemfile.lock
Gemfile.local
......@@ -6,3 +6,4 @@ facterversion = ENV.key?('FACTER_VERSION') ? ENV['FACTER_VERSION'] : ['>= 1.6']
gem 'puppet', puppetversion
gem 'puppetlabs_spec_helper', '>= 0.1.0'
gem 'facter', facterversion
gem 'coveralls', :require => false
......@@ -2,6 +2,7 @@ Puppet RPMKEY Module
====================
[![Build Status](https://travis-ci.org/stschulte/puppet-rpmkey.png?branch=master)](https://travis-ci.org/stschulte/puppet-rpmkey)
[![Coverage Status](https://coveralls.io/repos/stschulte/puppet-rpmkey/badge.svg)](https://coveralls.io/r/stschulte/puppet-rpmkey)
[![Puppet Forge](https://img.shields.io/puppetforge/v/stschulte/rpmkey.svg)](https://forge.puppetlabs.com/stschulte/rpmkey)
This repository aims to ease the GPG keymanagement with rpm
......
require 'rubygems'
require 'simplecov'
require 'coveralls'
require 'puppetlabs_spec_helper/module_spec_helper'
SimpleCov.formatter = SimpleCov::Formatter::MultiFormatter[
SimpleCov::Formatter::HTMLFormatter,
Coveralls::SimpleCov::Formatter
]
SimpleCov.start
SimpleCov.start do
add_filter 'spec/'
end
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment