Commit 409204b2 authored by mh's avatar mh

use different gems for different platforms

parent d2926b25
Pipeline #3372 failed with stages
in 4 minutes and 51 seconds
...@@ -9,10 +9,10 @@ ...@@ -9,10 +9,10 @@
%define version_gems1 activerecord --version '~> 4.2.9' %define version_gems1 activerecord --version '~> 4.2.9'
%define version_gems2 actionmailer --version '~> 4.2.9' %define version_gems2 actionmailer --version '~> 4.2.9'
# we don't need sinatra oder openoffice in jruby # we don't need sinatra oder openoffice in jruby
%define mrionly_gems sinatra roo simpleidn %define mrionly_gems sinatra roo simpleidn sha3
%define mrionly_gems_version1 pg --version '= 0.20' %define mrionly_gems_version1 pg --version '= 0.20'
# we want the jruby version of pg # we want the jruby version of pg
%define jrubyonly_gems jruby-pg %define jrubyonly_gems jruby-pg sha3-pure-ruby
%define checkout %(date +%Y%m%d) %define checkout %(date +%Y%m%d)
...@@ -135,6 +135,9 @@ chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/gems/unf_ext-*/lib ...@@ -135,6 +135,9 @@ chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/gems/unf_ext-*/lib
chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/gems/pg-*/ext/pg_ext.so chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/gems/pg-*/ext/pg_ext.so
chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/gems/pg-*/lib/pg_ext.so chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/gems/pg-*/lib/pg_ext.so
chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/gems/ed25519-*/ext/ed25519_ref10/ed25519_ref10.so
chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/gems/ed25519-*/lib/ed25519_ref10.so
%files -n puppet-agent-extensions %files -n puppet-agent-extensions
%defattr(-,root,root,-) %defattr(-,root,root,-)
%{agentdir}/bin/trocla %{agentdir}/bin/trocla
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment