Commit 6988bdec authored by mh's avatar mh

ensure we take puppet 7

parent cc8ffa3b
Pipeline #4634 failed with stages
in 6 minutes and 45 seconds
......@@ -32,8 +32,8 @@ License: GPLv3
Source0: puppetserver.conf
Patch0: https://github.com/duritong/ip/commit/0cf261fa2fb75113c94fef5ac231f3d7b2f3ff4c.patch
BuildRequires: puppet-agent >= 6.0
BuildRequires: puppetserver >= 6.0
BuildRequires: puppet-agent >= 7.0
BuildRequires: puppetserver >= 7.0
%if 0%{?rhel} >= 8
BuildRequires: postgresql
BuildRequires: postgresql-devel
......@@ -45,7 +45,7 @@ BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: gcc-c++
BuildRequires: chrpath
Requires: puppet-agent >= 6.0
Requires: puppet-agent >= 7.0
%description
......@@ -57,14 +57,14 @@ A set of gems for puppet agent & server
%package -n puppet-agent-extensions
Summary: Extension for the puppet-agent.
Requires: puppet-agent >= 6.0
Requires: puppet-agent >= 7.0
%description -n puppet-agent-extensions
A set of gem extensions packaged for the puppet-agent.
%package -n puppetserver-extensions
Summary: Extension for the puppetserver.
Requires: puppetserver >= 6.0
Requires: puppetserver >= 7.0
%description -n puppetserver-extensions
A set of gem extensions packaged for the puppetserver.
......
[puppet]
name=Puppet Repository el 7 - $basearch
baseurl=http://yum.puppetlabs.com/puppet/el/7/x86_64
baseurl=http://yum.puppetlabs.com/puppet7/el/7/x86_64/
gpgkey=http://yum.puppetlabs.com/RPM-GPG-KEY-puppet
enabled=1
......
[puppet]
name=Puppet Repository el 8 - $basearch
baseurl=http://yum.puppetlabs.com/puppet/el/8/x86_64
baseurl=http://yum.puppetlabs.com/puppet7/el/8/x86_64
gpgkey=http://yum.puppetlabs.com/RPM-GPG-KEY-puppet
enabled=1
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment