Commit 8b4d42f1 authored by mh's avatar mh
Browse files

add more deps that we need

parent d0c50029
%if 0%{?_version:1} %if 0%{?_version:1}
%define _verstr %{_version} %define _verstr %{_version}
%else %else
%define _verstr 0.0.1 %define _verstr 0.0.2
%endif %endif
%define checkout %(date +%Y%m%d) %define checkout %(date +%Y%m%d)
...@@ -19,6 +19,8 @@ Source0: puppetserver.conf ...@@ -19,6 +19,8 @@ Source0: puppetserver.conf
BuildRequires: puppet-agent >= 5.0 BuildRequires: puppet-agent >= 5.0
BuildRequires: puppetserver >= 5.0 BuildRequires: puppetserver >= 5.0
BuildRequires: postgresql96
BuildRequires: postgresql96-devel
%description %description
...@@ -53,7 +55,8 @@ echo -e "[master]\nconfdir=~/puppet\ncodedir=~/puppetcode" > ~/.puppetlabs/etc/p ...@@ -53,7 +55,8 @@ echo -e "[master]\nconfdir=~/puppet\ncodedir=~/puppetcode" > ~/.puppetlabs/etc/p
%build %build
/opt/puppetlabs/puppet/bin/gem install --lock --install-dir ./agent_gems --no-ri --no-rdoc -N trocla iuid export PATH=$PATH:/usr/pgsql-9.6/bin
/opt/puppetlabs/puppet/bin/gem install --lock --install-dir ./agent_gems --no-ri --no-rdoc -N trocla iuid base32 ip pg
# so it picks up the right config # so it picks up the right config
export JAVA_BIN=/usr/bin/java export JAVA_BIN=/usr/bin/java
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment