Commit baecaaa0 authored by mh's avatar mh
Browse files

correct path

parent a5818184
Pipeline #1586 failed with stages
in 4 minutes and 12 seconds
......@@ -35,6 +35,7 @@ BuildRequires: postgresql96-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: gcc-c++
BuildRequires: chrpath
Requires: puppet-agent >= 6.0
%description
......@@ -120,10 +121,10 @@ for d in bin specifications gems; do
mv ./server_gems/${d} %{buildroot}%{servergemdir}/
done
chrpath -d /opt/puppetlabs/puppet/lib/ruby/gems/*/extensions/x86_64-linux/*/bcrypt-*/bcrypt_ext.so
chrpath -d /opt/puppetlabs/puppet/lib/ruby/gems/*/extensions/x86_64-linux/*/nokogiri-*/nokogiri/nokogiri.so
chrpath -d /opt/puppetlabs/puppet/lib/ruby/gems/*/extensions/x86_64-linux/*/unf_ext-*/unf_ext.so
chrpath -d /opt/puppetlabs/puppet/lib/ruby/gems/*/extensions/x86_64-linux/*/pg-*/pg_ext.so
chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/extensions/x86_64-linux/*/bcrypt-*/bcrypt_ext.so
chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/extensions/x86_64-linux/*/nokogiri-*/nokogiri/nokogiri.so
chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/extensions/x86_64-linux/*/unf_ext-*/unf_ext.so
chrpath -d %{buildroot}/opt/puppetlabs/puppet/lib/ruby/gems/*/extensions/x86_64-linux/*/pg-*/pg_ext.so
%files -n puppet-agent-extensions
%defattr(-,root,root,-)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment