Commit d3701a28 authored by mh's avatar mh
Browse files

upgrade to puppet 6

parent c0abb899
%if 0%{?_version:1}
%define _verstr %{_version}
%else
%define _verstr 0.0.10
%define _verstr 0.0.11
%endif
# puppetserver still runs a ruby 1.9.3 kind JRuby
......@@ -17,7 +17,7 @@
%define checkout %(date +%Y%m%d)
%define agentdir /opt/puppetlabs/puppet
%define agentgemdir %{agentdir}/lib/ruby/gems/2.4.0/
%define agentgemdir %{agentdir}/lib/ruby/gems/2.5.0/
%define servergemdir /opt/puppetlabs/server/data/puppetserver/jruby-gems
Name: puppet-extensions
......@@ -28,32 +28,32 @@ License: GPLv3
Source0: puppetserver.conf
Patch0: https://github.com/erikh/ip/commit/0cf261fa2fb75113c94fef5ac231f3d7b2f3ff4c.patch
BuildRequires: puppet-agent >= 5.0
BuildRequires: puppetserver >= 5.0
BuildRequires: puppet-agent >= 6.0
BuildRequires: puppetserver >= 6.0
BuildRequires: postgresql96
BuildRequires: postgresql96-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
Requires: puppet-agent >= 6.0
%description
A set of gems for puppet agent & server
Requires: puppet-agent >= 5.0
%filter_requires_in %agentgemdir
%filter_setup
%package -n puppet-agent-extensions
Summary: Extension for the puppet-agent.
Requires: puppet-agent >= 5.0
Requires: puppet-agent >= 6.0
%description -n puppet-agent-extensions
A set of gem extensions packaged for the puppet-agent.
%package -n puppetserver-extensions
Summary: Extension for the puppetserver.
Requires: puppetserver >= 5.0
Requires: puppetserver >= 6.0
%description -n puppetserver-extensions
A set of gem extensions packaged for the puppetserver.
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment